Page 1 of 2 12 LastLast
Results 1 to 15 of 17
  1. #1

    obtaining ip address ......

    Hi, I'm new to this. I have a new phone Coolpad 5210S. It uses Android version 2.3.5 Kernel 2.6.38.6-perf+

    At home, I want to connect to my wireless network. It sees it, very strong signal. I enter the WPA password, it says 'obtaining ip address' ...... and that is a far as it goes. Never gets there, can't connect.

    Do you think this is because the phone is somehow blocked by the isp? I got the phone as part of a deal with the isp China Telecom. They did say if I want to use mobile internet, I should first phone 10000 and set it up. But I thought at home, I should be able to just connect to my wifi anyway.

    Any tips out there??

  2. #2
    Member
    Join Date
    Sep 2012
    Location
    Cambodia
    Posts
    14

    Device(s)
    Samsung galaxy S Duos Samsung galaxy note 2 (currently stolen)
    connec5ion to wifi depends on wifi configuration and NOT nn ISP who is beyond wife.
    look at your wifi router settings = password and encryption

    if it is your own wifi router - just for testing you may first configure OPEN wifi
    then later change to WPA/WPA2 PSK security in your router
    I travel for work and use at home and daily outside as well ANY and ever wifi router available and ALL so far connected properly.

    Your mentioned ISP connection only is needed if you directly connect to your ISP 3G network


    Good luck
    above is successfully tested on various samsung galaxy models


    Cyberspace Ashram for Kriya Yoga, God and Love. FREE download of teachings of love "Spiritual Treasures - Final Edition" 39988 files 3.55 GB and "5000+ free nature pictures Philippine islands" 34GB.

  3. #3
    I am using my own router at home. The password is correct. But it can't connect! The telephone can connect to an open network say in a restaurant. My computer also can't connect to the wifi. That is to say, if I use Linux. When I use Windows, it works. Android is Linux based, so there seems to be a common problem.



  4. #4
    Member
    Join Date
    Sep 2012
    Location
    Cambodia
    Posts
    14

    Device(s)
    Samsung galaxy S Duos Samsung galaxy note 2 (currently stolen)
    I also use linux - since 15 yrs
    and yes LONG time ago - some 5+ or more years ago there was a problem connecting linux to encrypted network .WEP was OK then anything else failed

    now we no longer use WEP but WPA/WPA2 PSK
    and WPA/WPA2 PSK works perfect with me since at least some 4-5 years
    on linux (opensuse fully updated) as well as on any android
    it may depend on your linux dist network-manager IF or NOT the encryption method is recognized automatically or needs to be chosen manually

    all samsung galaxy devices from android 3.x to 4.x always have connected to any public router when password entered,


    Cyberspace Ashram for Kriya Yoga, God and Love. FREE download of teachings of love "Spiritual Treasures - Final Edition" 39988 files 3.55 GB and "5000+ free nature pictures Philippine islands" 34GB.

  5. #5
    Thanks, and sorry to hear about your King. He was a good man, well respected even by Chinese leaders such as Chouenlai.

    This is an ongoing problem for me at home. The wireless refuses to work under Linux Ubuntu or Fedora, and now Android. My hardware is ok, my computer and my phone say they are connected, but there is no internet connection if I don't plug the cable in. I have asked many people many times, but no one has an answer.



  6. #6
    Member
    Join Date
    Sep 2012
    Location
    Cambodia
    Posts
    14

    Device(s)
    Samsung galaxy S Duos Samsung galaxy note 2 (currently stolen)
    your problem is an incompatibility between router and linux/android

    as mentioned first above

    login to your router
    if ever done before:
    use cable and connect your laptop directly to your router
    in any browser such as FFX open the IP of your router, usually
    192.168.0.1
    it also can be different, if doubt - go windows, command prompt
    ipconfig
    then you see the IP for router

    in Linux, connected in browser to your router,
    you see the GUI of your router
    if asked for password/user
    either YOU set that or who ever configured OR factory default
    Google for your router model to find default factory pwd/user

    backup existing router config to your laptop, in the admin section of router there is such feature for all common router brands I know

    now in router DISABLE ANY security to make your wlan OPEN,
    safe settings
    reboot router

    in your linux machine
    what network manager are you using
    many years back the KDE network manager failed to work properly for above reasons
    no idea ho it is NOW
    while I run KDE as desktop
    my network manager is GNOME

    the applet used and put in system tray for easy configuration of wlan/3G and LAN configuration is

    nm-applet

    see if you have it

    whereis nm-applet
    nm-applet: /usr/bin/nm-applet

    else
    install your gnome version of network manager

    if NO network applet in your system-tray
    use in CLI

    nm-applet

    and the applet should appear there

    configure your wifi access in gnome network manager applet

    and test www access
    if OK
    set in your router security to
    WPA/WPA2 PSK

    make sure you have all relevant packages in your linux installed for WPA/WPA2 PSK !!

    it definitely is NO android problem but a BASIC router config problem best solved in linux to router connections. if your linux workinng, then also android working

    in worst case for router you can reset router to factory values
    they normally ALWAYS pe3rfect for all normal home wlan

    if EVER you get shortest power cut offs (we have that in countries I work and live the past 13 yrs, then connection to router OK but to www NOT OK,
    solution:
    router power OFF
    wait half minute. then
    power ON

    thats what I have HERE in the guesthouse almost every day once

    in windows repair network connection
    in linux = restart network

    cardinal rule in life

    big problems have small cause

    God bless

    PS
    about our king
    no need to be sorry
    when ppl drop body
    then they alive and free to spiritually move on
    more alive than when imprisonned in body while on earth

    king happy NOW = more than before
    those left behind have reason to be sorry for self for having failed to move on


    Cyberspace Ashram for Kriya Yoga, God and Love. FREE download of teachings of love "Spiritual Treasures - Final Edition" 39988 files 3.55 GB and "5000+ free nature pictures Philippine islands" 34GB.

  7. #7

    screenshot

    Thanks again.
    I'll try your advice and get back to you. I already have nm set up and running. I know the hardware is ok, because I can use the wireless at work or in a restaurant. My device is 192.168.1.1 I can access it, but the access is very slow.

    Please see the screenshot: Primary DNS for wifi is 192.168.1.1 Maybe that is the problem, it can't find any web pages. But I can't reset that in the router.

    If I connect to the wifi from my laptop with Windows, I have to tell Windows to make the dsl cable connection, even when the cable is not plugged in. Only then will the wifi work. I don't understand why this is so.
    Attached Images Attached Images



  8. #8
    Member
    Join Date
    Sep 2012
    Location
    Cambodia
    Posts
    14

    Device(s)
    Samsung galaxy S Duos Samsung galaxy note 2 (currently stolen)
    If working but slow, it may be DNS problem,

    your current DNS = 192.168.1.1
    is a setting found in many routers and is the cache of your ISP DNS
    you could replace it with any other, or better

    if you have bind installed on your linux box, AND started,

    in your gnome network manager you may set DNS to

    127.0.0.1

    and then your own default bind will to name resolving from ROOT server without further configuration and bypassing any ISP or gov controlled DNS.

    in your
    /etc/named.conf
    you should find existing default config lines:

    zone "." in {
    type hint;
    file "root.hint";
    };


    that will do the job without further configuration changes.

    I use that since some 10 yrs to be free from ISP DNS, which sometimes is censured and blocks (misses) huge A-blocks of IPs. or entire server hosting farms.

    in your server configuration you make sure your bind is started at boot by default.

    then test your own DNS with any domain, example in CLI:

    dig kriyayoga.com

    and at then at the very bottom of your output you see

    ;; Query time: 722 msec
    ;; SERVER: 127.0.0.1#53(127.0.0.1)


    you see the IP of DNS used = your localhost, and the time used to resolve = 722msec

    that is long because its first time today to connect to ROOT servers.
    if you repeat same NS query, you then see some benefits:

    ;; Query time: 26 msec
    ;; SERVER: 127.0.0.1#53(127.0.0.1)


    because now that query is cached in your local linux box.

    the key point however is to bypass ISP or gov control to have and enjoy self-control

    I leave secondary DNS blank
    you cold enter one of the free google DNS

    IP addresses 8.8.8.8 and 8.8.4.4
    or any other free public DNS
    but then again you depend on ISP giving you access to that IP!
    my own NS always running = NO secondary needed.

    and one more point

    you may of course start to test your internet connection using laptop to router via cable to bypass one possible problem with wifi configuration.

    I usually do a factory reset of router and work perfectly with default setting except for security settings and any possible if ISP requires password/username to access, some routers have such setting options (Dlink for example).

    Years ago in the Philippines one major ISP had such access control and required router (or computer) to know ISP access data.

    In recent years, I use 3G mostly and all works simple default and all public wifi hotspots in restaurants and hotels use simple router default settings
    and those who have router configured by ISP = the ISP-tech support HERE spent 3 days for 3 routers with the result = ALL working default settings messed UP and router connection fragile/erratic sometimes.


    God bless


    Cyberspace Ashram for Kriya Yoga, God and Love. FREE download of teachings of love "Spiritual Treasures - Final Edition" 39988 files 3.55 GB and "5000+ free nature pictures Philippine islands" 34GB.

  9. #9
    Hi again. I set the router to 'open' but my mobile phone still can't use it. The phone says it is connected to ChinaNet-zgbJ, but there is not internet. Also my laptop says it is connected but there is no internet.

    I will borrow another router from someone, connect it at home, and see if it works!



  10. #10
    Member
    Join Date
    Sep 2012
    Location
    Cambodia
    Posts
    14

    Device(s)
    Samsung galaxy S Duos Samsung galaxy note 2 (currently stolen)
    Did you fix the DNS
    for your computer 127.0.0.1 IN YOUR linux box gnome network manager applet
    and for the phone set in the router a public Google DNS as a.m.


    Cyberspace Ashram for Kriya Yoga, God and Love. FREE download of teachings of love "Spiritual Treasures - Final Edition" 39988 files 3.55 GB and "5000+ free nature pictures Philippine islands" 34GB.

  11. #11
    There is no file named.conf on this computer.

    I have tried setting the dns in nm, but that does not fix the problem. As I said, this has been going on for a long time now with my computer and Linux, but I only just got the Android phone. Maybe China Telecom block this deliberately, so that I have to use the telephone data connection which costs money and not the wifi, which is free, apart from the yearly internet fee.



  12. #12
    Member
    Join Date
    Sep 2012
    Location
    Cambodia
    Posts
    14

    Device(s)
    Samsung galaxy S Duos Samsung galaxy note 2 (currently stolen)
    setting up your own 127.0.0.1 DNS on localhost
    requires as said above the package
    bind
    installed on your linux machine
    and all relevant tools

    if you configure your router with Google DNS
    then of course no local host DNS needed


    Cyberspace Ashram for Kriya Yoga, God and Love. FREE download of teachings of love "Spiritual Treasures - Final Edition" 39988 files 3.55 GB and "5000+ free nature pictures Philippine islands" 34GB.

  13. #13
    Ubuntu,which I use most of the time, works fine as it is. I am reluctant to change things I don't understand. But look at this, see if it gives you a clue about what exactly is wrong.

    Someone told me to run this on my laptop:

    pedro@pedro-bedro:~$ nslookup web.qq.com
    Server: 127.0.0.1
    Address: 127.0.0.1#53

    Non-authoritative answer:
    web.qq.com canonical name = web2.qq.com.
    Name: web2.qq.com
    Address: 183.60.3.84
    Name: web2.qq.com
    Address: 183.62.126.217
    Name: web2.qq.com
    Address: 183.60.3.126
    Name: web2.qq.com
    Address: 121.14.74.112

    pedro@pedro-bedro:~$

    and at the same time run this:

    pedro@pedro-bedro:~$ sudo tcpdump -i wlan0 -vn port 53
    [sudo] password for pedro:
    tcpdump: listening on wlan0, link-type EN10MB (Ethernet), capture size 65535 bytes
    07:05:09.322452 IP (tos 0x0, ttl 64, id 0, offset 0, flags [DF], proto UDP (17), length 55)
    192.168.1.4.44891 > 192.168.1.1.53: 51356+ A? baidu.com. (27)
    07:05:09.325613 IP (tos 0x0, ttl 64, id 0, offset 0, flags [DF], proto UDP (17), length 55)
    192.168.1.1.53 > 192.168.1.4.44891: 51356 Refused 0/0/0 (27)
    07:05:30.678848 IP (tos 0x0, ttl 64, id 0, offset 0, flags [DF], proto UDP (17), length 60)
    192.168.1.4.34747 > 192.168.1.1.53: 24042+ A? tj.qstatic.com. (32)
    07:05:30.683109 IP (tos 0x0, ttl 64, id 0, offset 0, flags [DF], proto UDP (17), length 60)
    192.168.1.1.53 > 192.168.1.4.34747: 24042 Refused 0/0/0 (32)
    07:06:10.289010 IP (tos 0x0, ttl 64, id 0, offset 0, flags [DF], proto UDP (17), length 62)
    192.168.1.4.58841 > 192.168.1.1.53: 42198+ A? nboard.nciku.com. (34)
    07:06:10.292560 IP (tos 0x0, ttl 64, id 0, offset 0, flags [DF], proto UDP (17), length 62)
    192.168.1.1.53 > 192.168.1.4.58841: 42198 Refused 0/0/0 (34)
    07:06:42.671737 IP (tos 0x0, ttl 64, id 0, offset 0, flags [DF], proto UDP (17), length 59)
    192.168.1.4.7091 > 192.168.1.1.53: 3138+ A? www.bbc.co.uk. (31)
    07:06:42.674722 IP (tos 0x0, ttl 64, id 0, offset 0, flags [DF], proto UDP (17), length 59)
    192.168.1.1.53 > 192.168.1.4.7091: 3138 Refused 0/0/0 (31)
    07:07:10.290107 IP (tos 0x0, ttl 64, id 0, offset 0, flags [DF], proto UDP (17), length 62)
    192.168.1.4.58863 > 192.168.1.1.53: 33531+ A? nboard.nciku.com. (34)
    07:07:10.293262 IP (tos 0x0, ttl 64, id 0, offset 0, flags [DF], proto UDP (17), length 62)
    192.168.1.1.53 > 192.168.1.4.58863: 33531 Refused 0/0/0 (34)
    07:07:43.855657 IP (tos 0x0, ttl 64, id 0, offset 0, flags [DF], proto UDP (17), length 59)
    192.168.1.4.32039 > 192.168.1.1.53: 32512+ A? www.bbc.co.uk. (31)
    07:08:10.288994 IP (tos 0x0, ttl 64, id 0, offset 0, flags [DF], proto UDP (17), length 62)
    192.168.1.4.17200 > 192.168.1.1.53: 37366+ A? nboard.nciku.com. (34)
    07:08:10.291992 IP (tos 0x0, ttl 64, id 0, offset 0, flags [DF], proto UDP (17), length 62)
    192.168.1.1.53 > 192.168.1.4.17200: 37366 Refused 0/0/0 (34)
    07:08:45.080348 IP (tos 0x0, ttl 64, id 0, offset 0, flags [DF], proto UDP (17), length 59)
    192.168.1.4.14305 > 192.168.1.1.53: 30877+ A? www.bbc.co.uk. (31)
    07:08:45.083224 IP (tos 0x0, ttl 64, id 0, offset 0, flags [DF], proto UDP (17), length 59)
    192.168.1.1.53 > 192.168.1.4.14305: 30877 Refused 0/0/0 (31)
    07:09:10.287703 IP (tos 0x0, ttl 64, id 0, offset 0, flags [DF], proto UDP (17), length 62)
    192.168.1.4.14023 > 192.168.1.1.53: 39037+ A? nboard.nciku.com. (34)
    07:09:10.291137 IP (tos 0x0, ttl 64, id 0, offset 0, flags [DF], proto UDP (17), length 62)
    192.168.1.1.53 > 192.168.1.4.14023: 39037 Refused 0/0/0 (34)
    07:09:46.305470 IP (tos 0x0, ttl 64, id 0, offset 0, flags [DF], proto UDP (17), length 59)
    192.168.1.4.30784 > 192.168.1.1.53: 57327+ A? www.bbc.co.uk. (31)
    07:09:46.308706 IP (tos 0x0, ttl 64, id 0, offset 0, flags [DF], proto UDP (17), length 59)
    192.168.1.1.53 > 192.168.1.4.30784: 57327 Refused 0/0/0 (31)
    ^C
    19 packets captured
    19 packets received by filter
    0 packets dropped by kernel
    pedro@pedro-bedro:~$

    I don't know what 'tcpdump -i wlan0 -vn port 53' does, but I can see, there are a lot of 'Refused' and my wifi does not work.

    Maybe there is a connection?? Can it be changed to 'Accepted'??? And how??



  14. #14
    Member
    Join Date
    Sep 2012
    Location
    Cambodia
    Posts
    14

    Device(s)
    Samsung galaxy S Duos Samsung galaxy note 2 (currently stolen)
    essence
    it is NO android problem
    and most likely NO linux problem neither
    just very basics about router configuration


    Cyberspace Ashram for Kriya Yoga, God and Love. FREE download of teachings of love "Spiritual Treasures - Final Edition" 39988 files 3.55 GB and "5000+ free nature pictures Philippine islands" 34GB.

  15. #15
    Yeah, I'm going to get another router and try that!



Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •