Results 1 to 2 of 2
  1. #1

    Can someone tell me how to prevent my android tablet from deleting user apps and appdata upon reset?

    First off here is my tablets information
    name: Cobalt tab s800
    model #: SW-ARMM8S
    android ver: 4.0.4/ICS

    don't confuse this name with the Archos 80 cobalt they are very different

    I bought a new, prerooted android tablet online about two weeks ago and I was very happy with it for a little while anyway. I know for sure that the problem didn,t exist until after I uninstalled some unimportant system apps (google books/magazines/music/maps etc.). Now everytime I reset my tablet all user apps and app data are wiped and my internal app storage is 0.00mb. The first thing I tried was a factory data reset but of course that didn't help since my device is basically doing that everytime it loses power anyway I also tried factory data resetting from recovery that didn't work either.

    I was stuck like this for a while until I realized I could use adb to push a file manager into system/app. I had a very hard time finding drivers for my tablet because it is so obscure and off brand but eventually i found something called universal adb driver installer which worked and I was able to mount sytem as rw and push es file explorer and rom toolbox pro onto my android.

    So luckily I had installed busybox before all of this happened and I have another rooted android device so i can download apps with it, back them up, transfer them over to my tablet's internal storage and use es file explorer to copy the apk into data/app. My tablet says that there is 0.00mb of app storage even though it is reporting that 128mb is being used by user apps. I have also figured out that I can backup all of my user apps and app data by copying everything in data/app and data/data into my sd card. So if my tablet ever restarts or dies I can use rom toolbox to mount my tablet as rw and then use es file explorer to copy all of my data back into place and then use rom toolbox to do a fast reboot (which doesn't turn off the power and so my data remains intact)
    and voila all of my data is restored.

    But doing all of that is a hassle and a half just to keep my data intact and did I mention that anytime I make even the smallest settings change in any of my apps I have to then backup that apps data which is extremely time consuming and error laiden. I have tried to change the permissions for data/data and data/app but all in vain because both of these folders are completely formatted anytime my device loses power.

    There is no custom recovery or custom roms available for this device.

  2. #2
    Member
    Join Date
    Mar 2014
    Location
    North Wales, UK.
    Posts
    1

    Device(s)
    Galaxy phone. Old decrepit 8" ICS tablet ( Chinese un-named ) running JB now :-) and more later.
    Hi,

    I may be wrong but did you notice "where" Busybox installed too?

    It is probable that it just installed to /system/xbin instead of system/bin/ or the other way round depending on which installer you used and version.

    This would give you the 0MB free issue and all the apps appear to have disappeared, now you have a filemanager installed just browse to system, bin or xbin and look to see where the "busybox" binary is and just symlink to the other dir.


    You might have to remount the system rw:

    mount -o rw,remount /dev/block/mmcblk0p1 /system

    Then just do the link.

    Once done and rebooted you "should" have everything back to normal with your apps.

    I have this problem if using the stericson installer and forget to change the destination dir to /system/bin/ ( which I forget every time ), there is nothing wrong with the installer just me. :-)

    I think that should all work.



Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •