See the top rated post in this thread. Click here

Results 1 to 9 of 9
  1. #1
    Member
    Join Date
    Feb 2012
    Location
    Caracas
    Posts
    22

    Unhappy Phone got stuck in a boot loop after attempting to unlock the bootloader

    Hi guys,

    I followed the official Sony guide to unlock the bootloader of my Xperia E (C1505) phone, used fastboot to enter the unlock code Sony sent me, but after doing it my phone is stuck in a boot loop. It starts to boot and I can see the boot animation, but then it just freezes and reboots. Does anyone have a clue about how to fix this?

    Thanks in advance for any help!

  2. #2
    Member
    Join Date
    Feb 2012
    Location
    Caracas
    Posts
    22

    Original Poster
    Managed to fix it using a program called Flash Tool, which flashes the original ROM into the device. However, I'm not sure whether I should attempt to flash Cyanogenmod into the device after this, since I wouldn't like to brick it for good. (Unlocking the bootloader was supposed to be something simple, but it got stuck in a bootloop).

    Anyway, any suggestions? I guess that if something goes wrong when attempting to install CM I could always flash the original ROM with Flash Tool, but I'm not sure.

    Thanks for any input you can give!



  3. #3
    Quote Originally Posted by odiseo77 View Post
    Managed to fix it using a program called Flash Tool, which flashes the original ROM into the device. However, I'm not sure whether I should attempt to flash Cyanogenmod into the device after this, since I wouldn't like to brick it for good. (Unlocking the bootloader was supposed to be something simple, but it got stuck in a bootloop).

    Anyway, any suggestions? I guess that if something goes wrong when attempting to install CM I could always flash the original ROM with Flash Tool, but I'm not sure.

    Thanks for any input you can give!
    Well, I would say at first things might have gone wrong because your device system may have ran onto some problems but I would say you can try doing that again if you want !!! Although the possibility or running onto the trouble will be their but I would say if you are following the footprints of sony blog then chances are less !! Move forward in unlocking the bootloader again !


    1 members found this post helpful.
    Peter Carlos
    Rapidsoft Technologies
    website:http://www.rapidsofttechnologies.com/

  4. #4
    Member
    Join Date
    Feb 2012
    Location
    Caracas
    Posts
    22

    Original Poster
    Hello Peter, thanks for your reply.

    Following a guide on installing CM on this device, I flashed a custom boot.img. After that, I need to boot in recovery mode in order to locate the new ROM inside the SD card and install it. The problem is, for some reason I can't boot in recovery mode; not sure whether I'm doing it wrong or there's a problem with my phone. Is recovery mode supposed to be available on every phone, or is it necessary to install something like CWM to be able to boot in recovery mode?



  5. #5
    Member
    Join Date
    Feb 2012
    Location
    Caracas
    Posts
    22

    Original Poster
    Quote Originally Posted by odiseo77 View Post
    Is recovery mode supposed to be available on every phone, or is it necessary to install something like CWM to be able to boot in recovery mode?
    Well, according to different tutorials I've read, it seems I need to install a custom recovery, so I'll try that first. I'm marking this as solved since the initial problem has been solved.

    Cheers!



  6. #6
    Quote Originally Posted by odiseo77 View Post
    Well, according to different tutorials I've read, it seems I need to install a custom recovery, so I'll try that first. I'm marking this as solved since the initial problem has been solved.

    Cheers!
    Great that seems that you already have the idea what you are dealing with, yes you are correct sometimes there is an need to install custom recovery, so try doing that first and keep me updated if you ran onto more of the confusion !


    1 members found this post helpful.
    Peter Carlos
    Rapidsoft Technologies
    website:http://www.rapidsofttechnologies.com/

  7. #7
    Member
    Join Date
    Feb 2012
    Location
    Caracas
    Posts
    22

    Original Poster
    Hello Peter, thanks for your interest!

    I was finally able to install Cyanogenmod on the phone. Indeed, I needed to install a custom recovery first in order to flash the CM zip file.

    Everything seems to be working fine except for the fact that on every boot I get en error message saying I need to reboot the device to access the mobile network (the phone works fine, nonetheless). I guess I'll have to open a new thread for this problem.

    Cheers!



  8. #8
    Quote Originally Posted by odiseo77 View Post
    Hello Peter, thanks for your interest!

    I was finally able to install Cyanogenmod on the phone. Indeed, I needed to install a custom recovery first in order to flash the CM zip file.

    Everything seems to be working fine except for the fact that on every boot I get en error message saying I need to reboot the device to access the mobile network (the phone works fine, nonetheless). I guess I'll have to open a new thread for this problem.

    Cheers!
    Well, that's weird !! anyway I guess opening a new thread will be much more better thing to do as it will help you in giving you good exposure at all !


    Peter Carlos
    Rapidsoft Technologies
    website:http://www.rapidsofttechnologies.com/

  9. #9
    I prefer using LEO Privacy Guard V 3.0 to lock my apps.
    You should give that a try!



Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •