I have a Samsung Note 2 with Android-4.4.2. It's about vintage 2012, and Samsung are not offering system updates to 5.0

http://www.androidorigin.com/samsung...d-5-0-release/

I now need an epilepsy monitor whose app requires Android-5.0 or higher. So it's upgrade, or replace. What mods or workarounds would you recommend?