Results 1 to 3 of 3
  1. #1

    Usb Won't Connect Kindle Fire To Windows 7

    I am brand new to rooting so please excuse the noob naiveté. I rooted my original version Kindle Fire with the stable version of Cyanogenmod 10.1.3. Everything went well until I tried to connect my Fire to my Windows 7 computer via USB cable. The computer will not connect to the Kindle Fire. When I go to the Device Manager I see the Kindle Fire listed as "Kindle" but I cannot communicate with the device. As per some other suggestions on the web I uninstalled the Kindle driver and tried to let Windows 7 install the correct driver. This has not worked. I tried to uninstall the current driver and use an older driver from Kindle Fire Utility 0.9.6 (I originally used version 0.9.8) but this too failed to be reconized and connect. Can anyone help me get my computer to recognize my Kindle Fire so I could transfer files? Thank you all in advance.

  2. #2
    How about testing the power of a reboot?

    1. Restart your PC
    2. Restart your Kindle 2
    3. Turn your Kindle OFF
    4. Connect your powered off Kindle 2 to your Win 7 64 bit PC

  3. #3

    Red face I am sucking syntax

    Installing the USB Driver (Windows Users)

    Perform the following steps if your development computer runs Windows.
    If you previously installed the now-deprecated Fire Phone SDK Add-on, as described in [Setting Up Your Development Environment][01-setting-up-your-development-environment], the USB driver for Fire tablets and Fire phone has already been downloaded along with the Add-on.
    If you have not downloaded the SDK Add-on or are new to Fire tablets development, you can directly download the driver from the following URL: [""]

    I would use Amazon's driver. Sorry for the sloppy post.

    Last edited by sum1nil; 06-15-2017 at 05:39 AM. Reason: Cannot post links

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts