Results 1 to 5 of 5
  1. #1

    questions concerning phone USB drivers

    Happy New Year

    I have been experiencing major headaches trying to get/install USB drivers for this phone (shw-m110s). Now I have 2 questions that need direct and factual answers. 1. Where, exactly, can I get these specific drivers? 2. Could these drivers be D/l and installed directly into the phone? I have good reasons for wanting them on the phone...if possible. Yes, I realize this is an older phone, but I dont think it should be so difficult to get and install these drivers. Anyone wish to offer good assisstance?

  2. #2
    It is a Samsung phone? You will find the drivers on Samsung website. just search your phone in Samsung website, with query of drivers.

    Looking for security app? Try Leo Privacy Guard 3.0.

    Join Our Christmas Contest by visiting our Facebook page "LEO Privacy Guard"

  3. #3
    To nilofar_iqbal

    Now you see the problems I run into. The site you mentioned does not list this phone. I have searched other sites and "supposedly" aquired the drivers there(?). But I am not sure the laptop I was using installed those drivers. Thus I will ask if I could install such drivers directly to phone?
    GalaxyS1--shw-m110s--android 2.2

  4. #4
    hey you need old android drivers and try to install on xp windows 32 bit for best performance.if still you have problem install samsung kies.

  5. #5
    To mayasim

    Yea, it didn't work! But that's not surprising. Everything I have tried to get this to work has failed. I know the drivers are for an older model. I know I can "supposedly" use KIES. I know this sh__ is supposed to work but NOTHING does! My god, how does anybody get anything accomplished? This is SUPPOSED to be a simple, easy task, yet I've been trying everything I can think of for about 5-6 months now and NOTHING works????? If you'd go back through my threads here and other sites, you'd notice nothing but failure and major frustration got accomplished. WHAT THE HELL is going on? (That question is for anyone/everyone who's care to venture an opinion). I know you're thinking I'm a complete idiot, but I swear I've done EVERYTHING flawlessly step-by-step and nothing works!!! I think the first and foremost problem lies in acquiring the drivers. And that is where all the problems begin. KIES did NOTHING, ODIN wouldn't work. Tried to have comp (MSWin7) find drivers and it just went on searching forever, never obtaining those driver(s). Look, I'm not bitchin' at anyone, but someone, somewhere has got to know what/where the problem lies and I'll bet it a very simple easy solution. So, I'm imploring anyone who knows about the Galaxy S and what may be the cause of this problem to PLEASE step up and help out.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts