Results 1 to 3 of 3
  1. #1

    Angry ICS 4.0.4 on Motorola razr Lost Wifi

    I will be honest, I have posted this on the Android bugs report site but did not get any replies so far.. I guess they are overwhelmed by the amount of problems this android OS creates....

    Same with Motorola. three times I tried to get support from them, nothing so far, they dont even reply to my emails... A real shame..

    After service provider (rogers canada) has pushed an OTA update from gingerbread to ice cream sandwich (4.0.4) I have several bugs that are making my usage of this phone a real nightmare.

    1-Wifi no longer works as it should.

    Symptoms are:

    • Wifi refuses to connect for no apparent reasons (I have installed the terminal emulator so I can see dmesg but within the android interface, nothing apparent)
    • A reboot of the wifi access point WILL allow the smartphone to connect to Wifi
    • The wifi connection will randomly disconnect on its own without warning (again looking on dmesg, I see about 1000 lines about power management features... My guess is that the kernel shuts down the wifi chip to save power and cant restore it)
    • Trying to reconnect will not work. A reboot of the access point is required.

    All of this is happening without touching neither device's configurations. The wifi access point is using WPA2 encryption. All other devices (windows laptops, iphones, ipads, even Linux laptops) can connect without problems.

    While on gingerbread, this issue never happened (2years+). Configuration of the access point has not changed. I tried to forget the network on the phone, reboot the access point, reconnect to the wifi, but to no avail. The issue persists. I also tried to "Factory reset" about 4 or 5 times... Nada!

    Whenever I try to connect, this can be seen by dmesg on the Android smartphone :

    1|app_166@umts_spyder:/ $ dmesg | grep wlan
    <6>[ 0.340820,0] print_constraints: vwlan1: 1800 <--> 1900 mV
    <6>[ 0.341644,0] print_constraints: vwlan2: 3300 mV
    <6>[ 5.130767,0] regulator_init_complete: vwlan1: disabling
    <6>[ 38.087188,0] ADDRCONF(NETDEV_UP): wlan0: link is not ready
    <7>[ 39.915771,0] wlan0: authenticate with 1c:af:f7:dd:7b:55 (try 1)
    <7>[ 39.919342,1] wlan0: 1c:af:f7:dd:7b:55 denied authentication (status 17)

    While the phone cant connect, the access point seems to think that the phone is connected as I can see it in the "Connected Clients List", while the phone is not connecting. with the error message above.

    Looking on Google, I am leaning toward a bug in ICS in regards to Wifi protection (WPA2).... Definitely on Android's side that I am 99.9% sure there are tons of people having the same (more or less) issue.... Anyways, this is not acceptable for a device I am paying for. Period. I have lost wifi so no more Exchange server sync which means potential problems with business matters. Like they said in Apollo 13 " Gentlemen, this is NOT acceptable!"

    Some info on the phone:

    Motorola Razr (Canadian Version)
    System version: 672.180.352.XT910.Rogers.en.CA
    Revision number: 02
    Model Number: XT910
    Android version: 4.0.4
    Firmware configuration version: GAS_NA_SPYDERICSROGERS_P012
    Baseband version: U_1C.76.FCP
    Webtop version: wt-3.0.0
    Kernel: 3.0.8-g35a1af9 hnvc47@zbr05lnxdroid11 #1
    SMP PREEMPT Tue Jul 24 11:39:41 BRT 2012
    Build number: 6.7.2-180_SLC-35

    Anybody cares to help?? Anything is appreciated since I expect to have 0.01% support from Motorola...

  2. #2
    Too late, I changed phone anyways so answering this thread would be only to help others.

  3. #3
    Senior Member
    Join Date
    May 2011
    Blog Entries

    Droidx, Xoom and Comcast MIFI Hotspot
    Did you try changing the channel on the Wifi Access point?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts